Issue with multiple applications

Incident Report for MathWorks

Resolved

All applications have been restored.
Posted Oct 20, 2025 - 17:50 EDT

Update

ThingSpeak Web and API are operating normally. Our team is actively investigating and monitoring the situation.
Posted Oct 20, 2025 - 15:43 EDT

Update

We are currently experiencing intermittent instability affecting our services due to issues with our cloud provider. Our team is actively investigating and monitoring the situation.
Posted Oct 20, 2025 - 14:59 EDT

Update

We are currently experiencing intermittent instability affecting our services due to issues with our cloud provider. Our team is actively investigating and monitoring the situation.
Posted Oct 20, 2025 - 14:57 EDT

Update

We are currently experiencing intermittent instability affecting our services due to issues with our cloud provider. Our team is actively investigating and monitoring the situation.
Posted Oct 20, 2025 - 13:55 EDT

Identified

We are currently experiencing intermittent instability affecting our services due to issues with our cloud provider. Our team is actively investigating and monitoring the situation.
Posted Oct 20, 2025 - 13:50 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:34 EDT

Update

ThingSpeak Web and API are currently degraded as the recovery proceeds. Users may get errors and data processing may be delayed.
Posted Oct 20, 2025 - 12:32 EDT

Monitoring

All applications have been restored. We will continue to monitor.
Posted Oct 20, 2025 - 08:53 EDT

Update

We are continuing working on restoring these applications.
Posted Oct 20, 2025 - 07:47 EDT

Update

Adding additional applications.
Posted Oct 20, 2025 - 06:08 EDT

Identified

Adding additional applications.
Posted Oct 20, 2025 - 06:07 EDT

Investigating

Multiple applications are impacted by a cloud provider issue. We are assessing and will update as we know more.
Posted Oct 20, 2025 - 04:39 EDT
This incident affected: Careers at MathWorks, Cloud Center, Downloads, License Center, MathWorks Store, MathWorks Account, MATLAB Answers, MATLAB Mobile, MATLAB Online, Online Courses App, and ThingSpeak.