MathWorks is currently working on an issue that has affected segments of our online systems.

We will provide further updates as soon as we can.

May 22, 2025 - 09:37 EDT

Thingspeak Web outage

Incident Report for MathWorks

Resolved

The issue with the application has been resolved.
Posted May 05, 2025 - 11:25 EDT

Identified

The Thingspeak web application is currently down.
Posted May 05, 2025 - 11:05 EDT
This incident affected: ThingSpeak.