This page displays real-time status and planned maintenance
updates for MathWorks applications. If you are
experiencing an outage that is not listed, please
submit a support
request.
Get email notifications whenever MathWorks creates, updates or resolves an incident.
Get text message notifications whenever MathWorks creates or resolves an incident.
Get webhook notifications whenever MathWorks creates an incident, updates an incident, resolves an incident or changes a component status.
Careers at MathWorks, Add-On Explorer, and MathWorks Store have been restored.
Posted 8 days ago. Jun 05, 2025 - 11:24 EDT
Update
MathWorks.com has been restored.
Posted 8 days ago. Jun 05, 2025 - 10:35 EDT
Update
MATLAB and Simulink Course Schedule has been restored.
Posted 8 days ago. Jun 04, 2025 - 15:51 EDT
Update
MathWorks Store has been restored. Some license options are not yet available. MATLAB and Simulink Course Schedule has been restored. Multi-attendee quotes are not yet available. License Center restored: product data, product allocation and adding new license administrators. License Center reports are not yet available.
Posted 9 days ago. Jun 03, 2025 - 14:04 EDT
Update
File Exchange has been restored however some earlier GitHub submissions may not have posted yet.
Posted 14 days ago. May 30, 2025 - 11:33 EDT
Update
MathWorks Account has been restored.
Posted 14 days ago. May 29, 2025 - 17:11 EDT
Update
Downloads has been restored.
License Center has been restored. You can now view and activate licenses, link to licenses, and manage users. However, it is currently operating in a degraded state, so detailed product data, product allocation, buying products, renewing maintenance, and adding new license administrators are not yet available.
Add-on Explorer is still in a degraded state. MathWorks Product downloads is now enabled. Self-serve trials of products not currently licensed for is not enabled.
Posted 15 days ago. May 28, 2025 - 21:31 EDT
Update
File Exchange - GitHub Sync, Hardware Support Packages and Support packages are operating normally. File Viewing is not enabled.
Add-on Explorer has been restored. It is operating in a degraded state with MathWorks products downloads not enabled.
Posted 16 days ago. May 28, 2025 - 12:21 EDT
Update
File Exchange - Installation of Hardware Support Packages is not currently enabled.
Posted 16 days ago. May 28, 2025 - 08:33 EDT
Update
MATLAB Answers and Cloud Center have been restored for existing users. File Exchange has been restored for existing users. It is operating in a degraded state with file viewing and GitHub sync not yet enabled.
Posted 17 days ago. May 27, 2025 - 13:04 EDT
Update
We are continuing to investigate this issue.
Posted 17 days ago. May 27, 2025 - 07:59 EDT
Update
MATLAB Grader and Cody have been restored for existing users.
Posted 17 days ago. May 26, 2025 - 15:06 EDT
Update
MathWorks experienced a ransomware attack. We have notified federal law enforcement of this matter. The attack affected our IT systems. Some of our online applications used by customers became unavailable, and certain internal systems used by staff became unavailable, beginning on Sunday, May 18. We have brought many of these systems back online and are continuing to bring other systems back online with the assistance of cybersecurity experts.
Posted 18 days ago. May 26, 2025 - 08:03 EDT
Update
Downloads is still in outage state.
Posted 20 days ago. May 24, 2025 - 11:30 EDT
Update
We are continuing to restore systems. More updates as they become available.
Posted 20 days ago. May 24, 2025 - 11:22 EDT
Update
Thingspeak has been restored for existing users.
MathWorks Account is experiencing degradation in service which is preventing users from creating new accounts. Some users who haven't signed in since 11 Oct 2024 will be unable to signin. Two step verification works intermittently.
Posted 20 days ago. May 23, 2025 - 20:10 EDT
Update
MATLAB Online and MATLAB Mobile have been restored. MathWorks Account is experiencing degradation in service which is preventing users from creating new accounts
Posted 21 days ago. May 23, 2025 - 09:41 EDT
Update
Updating MATLAB Answers status to Outage.
Posted 21 days ago. May 22, 2025 - 14:57 EDT
Update
Adding Cloud Center and MATLAB Mobile to impacted applications.
Posted 22 days ago. May 21, 2025 - 16:14 EDT
Update
Degradation: As of today, MathWorks Account SSO (Single Sign On) and Multi-factor authentication (MFA) are now working, which should fix many of the Sign-On and access issues users have experienced.
Posted 22 days ago. May 21, 2025 - 15:45 EDT
Update
Adding ThingSpeak to the list of affected applications.
Posted 24 days ago. May 20, 2025 - 10:18 EDT
Update
We are continuing to investigate this issue.
Posted 24 days ago. May 19, 2025 - 17:05 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. May 19, 2025 - 09:48 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. May 19, 2025 - 09:46 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. May 19, 2025 - 08:54 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. May 19, 2025 - 08:28 EDT
Update
We are continuing to investigate this ongoing issue. We will provide updates as they become available.
Posted 25 days ago. May 18, 2025 - 23:41 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. May 18, 2025 - 20:51 EDT
Update
We are continuing to investigate this issue.
Posted 25 days ago. May 18, 2025 - 19:54 EDT
Investigating
There is an issue with multiple applications. We are assessing impact and investigating the cause.
Posted 25 days ago. May 18, 2025 - 19:54 EDT
This incident affected: Add-On Explorer, Careers at MathWorks, Cloud Center, Cody, Downloads, File Exchange, License Center, MathWorks.com, MathWorks Store, MATLAB and Simulink Course Schedule, MathWorks Account, MATLAB Answers, MATLAB Grader, MATLAB Mobile, MATLAB Online, and ThingSpeak.